Skip to main content

MySql: Auto_Increment Column: All About Insert Values

Let's say we want to create a table in which each row will get unique id while inserting new row, means while we're inserting new row that particular column-value will be automatically inserted with unique integer value.
In this scenario we can use "AUTO_INCREMENT" column type.

-- drop table if exists
DROP TABLE IF EXISTS `TEST_AUTO_INCREMENT`

-- create a dummy table
CREATE TABLE TEST_AUTO_INCREMENT
  (
     Id INT AUTO_INCREMENT PRIMARY KEY
     , FirstName CHAR(40)
  )

-- AUTO_INCREMENT is applicable only with following data-types (integral data-types)
  TINYINT
  SMALLINT
  MEDIUMINT
  INT
  BIGINT

  DOUBLE

-- we can insert auto-increment values in different ways
-- If want to use the database generated vaules

  either don't include the AUTO_INCREMENT column into the insert statement
 
INSERT INTO TEST_AUTO_INCREMENT (FirstName) VALUES ('SriRam');


  or if we're considering that column too then use (0, '', NULL, DEFAULT) key-word or SET qualifier

INSERT INTO TEST_AUTO_INCREMENT (Id, FirstName) VALUES ('','Ram');
INSERT INTO TEST_AUTO_INCREMENT (Id, FirstName) VALUES (DEFAULT,'Shyam');
INSERT INTO TEST_AUTO_INCREMENT (Id, FirstName) VALUES (NULL,'Mohan');
INSERT INTO TEST_AUTO_INCREMENT (Id, FirstName) VALUES (0,'Sohan');


INSERT INTO TEST_AUTO_INCREMENT SET FirstName='ShyamMohan-1';

-- If we want to use the self-specified values
INSERT INTO TEST_AUTO_INCREMENT VALUES (11,'Krishna');
INSERT INTO TEST_AUTO_INCREMENT SET Id = 20, FirstName='ShyamMohan-2';




After executing all these statements we can see the result like this.

  
Auto_Increment Insert Queires & Result

In next section we'll discuss how to reset the increment value, should we use LAST_INSERT_ID()
or not, how does auto_increment behave after restarting MySql instance, what happen if column's max size got exceeded (e.g. if we're using tinyint as column data-type and trying to insert values as 234).

Comments

Popular posts from this blog

EFCore - Collate function

Search in SQL server query is generally case insensitive (by default or based on database level collation). Suppose we have an employees table with a row having first-name column value as "My-First-Name", so if we want to do the case-sensitive search we have to explicitly use the related collate: In EF 5 (currently in Release Candidate version [RC.2.20475.6]) Collate function got introduced which helps us to use our specific collation based search.  C# with EF5 code sample: var employeeCaseSensitiveSearch = _dbContext.Employees .Where(x => EF.Functions.Collate(x.FirstName, "Latin1_General_CS_AS") == "my-first-name") .FirstOrDefault(); A related database query will be something like this: T-SQL: Case sensitive search (use specific collation e.g.: Latin1_General_CS_AS) SELECT * FROM dbo.Employees AS e WHERE e.FirstName Collate Latin1_General_CS_AS = 'my-first-name' Some of the useful CSharp function which g...

Azure SQL - User management with Active Directory Group

To manage the user's roles we use Service Account on OnPrem/IaaS servers. We can use this service account on our SQL Server and accordingly manage users' permissions for the users who are part of this service account. Suppose we have an Azure SQL and we want to manage set-of-users permission shall we create each-and-every users' user profile in Azure SQL and set the permissions accordingly. Obviously, we will not .  If we've anything like Service Account (or Group) on Azure we could create the user of this GROUP on Azure SQL and set its permission/role. Here comes the Azure Active Directory Group to help us.  In case if our organization has some scheduled tasks to sync Active Directory (service account) to Azure Active Directory (AAD group), already in place, there will be some delay when we add a user to the Service account and get reflected in the AAD Group. If we have a requirement that as soon as we add a user to our group we wan...

Azure VM - Failed to update virtual machine disks (Solved)

Sometimes while trying to add/remove a disk from Azure VM through the Azure portal we are getting error like " Failed to update virtual machine disks " as below Here though we are only trying to add/remove the disk, we're not doing anything with Azure Disk Encryption (ADE), still, we're getting the error message related to ADE.  Not while adding or updating the disk, if we try to add extensions or performing any activity required to do save operation to update the VM template, it show a similar failure message which is related to ADE.  Now to resolve this if we disable the disk encryption through the Azure portal through it will disable the disk encryption and on portal, we can see there is no disk encryption and also the related Key vault field is coming up empty but still, when we try to add/remove the disk & do the save operation we are getting the similar message. This is because in the VM JSON template we can se...